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1.0 Introduction 

A PSCAD model of the region covered by grid zones 9, 10, 11, 12 was developed for asset owners to 
conduct their own Electromagnetic Transient (EMT) connection studies in this region as per 
Connection Study Requirements for New Generating Assets (GL-EA-0953)1. The model represents in 
detail the Upper South Island (USI), which is composed of grid zones 9, 10, 11, 12, while the rest of 
the South Island network is represented by equivalent voltage sources and a simplified network. The 
model contains synchronous generator models with their respective automatic voltage regulators 
(AVR) and reactive power compensation devices represented using simplified generic models. 

The EMT network model components were created using E-TRAN software developed by Electranix 
Corporation2. The power-flow solution and network equivalent were created using DigSILENT 
PowerFactory. This document provides guidance for loading the network model into PSCAD, along 
with brief descriptions of the models.   

  

 

1 Connecting generation | Transpower 
2 E-TRAN Runtime library for PSCAD | Electranix Corporation 

https://www.transpower.co.nz/system-operator/information-industry/asset-owner-requirements/connecting-generation
https://www.electranix.com/software/e-tran-runtime-library-for-pscad/
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2.0 Files Provided by the System Operator  

The system operator provides the asset owner with the GZ_9_10_11_12_EMT_model.zip package 
containing the files shown in Figure 1.  

 

Table 1 includes descriptions of the files provided in the .zip package.  

 

Figure 1: Files provided in the .zip package. 

 

Table 1: Description of the files provided. 

File Name Description 

dynamics.dyr Dynamic record file for generator and AVR/exciter models. This file 

should be placed in the same folder as the EMT_9_10_11_12.pscx case. 

EMT_9_10_11_12.pscx  A simulation file containing South Island grid zones 9, 10, 11, 12 in detail. 

The USI model has equivalent boundaries at TWZ 220 kV, NWD 220 kV 

and TIM 110 kV buses. 

ETRAN.pslx The runtime library developed by Electranix to be used with E-TRAN-

converted PSCAD files. The latest version of this library is freely available 

on the Electranix’ website3. 

ETRAN_IF12.lib The encrypted source code file for the E-TRAN runtime library. This 

should be loaded as a resource file in the ETRAN.pslx library. 

loads.csv A .csv file containing details of loads within the network model. The data 

is obtained by the PowerFactory power-flow solution. 

 

3 E-TRAN Runtime library for PSCAD | Electranix Corporation 

https://www.electranix.com/software/e-tran-runtime-library-for-pscad/
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File Name Description 

synchronous_machines.csv A .csv file containing details of the synchronous machines within the 

network model. The data is obtained from the PowerFactory power-flow 

solution. 

update_loads.py A python file used to update the load values based on the power-flow 

details provided by the loads.csv file. 

update_syncmachines.py A python file used to update the initial conditions of synchronous 

machines based on the power-flow details provided by the 

synchronous_machines.csv file. 

WP_USI.pswx This is a PSCAD workspace file which should load all necessary files into 

the PSCAD workspace to run the PSCAD case. 
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3.0 Setting up the Study Case 

The package is created using PSCAD V5.0.2 with Intel Fortran Classic 2021.12.0 compiler and Visual 
Studio 2022 installed. Loading the package into older PSCAD versions and/or with an older Intel 
Fortran compiler and Visual Studio version may cause the study case to fail. This section explains the 
steps required to load the study case. 

   

3.1 Loading the Case File and General Setup 

Once the provided .zip file is extracted, the user can open the WP_USI.pswx workspace file. This 
should load all necessary files and resources into the PSCAD environment. If the workspace fails to 
load correctly, the user can follow the sequence below to load all the files manually. 

Use the File -> Open command from PSCAD to load both files below.   

1. ETRAN.pslx 
2. EMT_9_10_11_12.pscx 

Once these two files are loaded, expand the ETRAN.pscx library by clicking the + sign beside the file 
name in the workspace. Right-click on the Resources subfolder and navigate to the Add -> Binary 
(*.o, *.obj, *.lib) submenu.   

 

Figure 2: Adding .lib files to the project. 

 

Then add the ETRAN_IF12.lib file as shown in Figure 3.  

 

Figure 3: All the .lib files loaded in correct order. 
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The following figure shows a snapshot of the PSCAD workspace after the workspace WP_USI.pswx 
has been correctly loaded.  

 

Figure 4: Screenshot of the correctly loaded PSCAD workspace and canvas. 

 

3.2 Case File Arrangement 

The network model is available within the Network Model subpage in the canvas. Figure 5 shows 
the layout of the network model. 

 

Figure 5: Layout of the network model. 
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3.3 Setting Up the Compiler 

An Intel® Fortran Compiler is required to run the simulation case. The simulation cases were 
developed using Intel® Fortran Compiler Classic 2021.12.0 compiler. The user must make sure a 
correct version of Intel Fortran compiler is installed on the computer4. The compiler can be selected 
by navigating to File -> Application Options -> Dependencies and selecting the correct Fortran 
compiler. Figure 6: Setting up the compiler. 

 

 shows the window to configure the Fortran compiler. 

 

 

Figure 6: Setting up the compiler. 

 

3.4 Setting Up the Project Simulation Time Step 

Setting up the correct simulation time step is crucial for accurate results. It is essential to run the 
simulation at a time step (solution time step) at 20 µs or below due to the modelling requirements. 
Users can use a slightly larger channel plot step to reduce the memory usage from the simulation. In 
this configuration, a 100 µs channel plot step is recommended. All these parameters can be changed 
in the Project Settings by right-clicking anywhere on the canvas as shown in Figure 7. 

 

4 Compatibility of compilers and Visual Studio versions with PSCAD versions can be found at 
https://www.pscad.com/knowledge-base/article/102  

https://www.pscad.com/knowledge-base/article/102
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Figure 7: Setting up the solution time step.  



TRANSPOWER NEW ZEALAND   |   GRID ZONE 9, 10, 11, 12 EMT MODEL USER GUIDE 8 

4.0 Simulation Case Details 

The simulation case was developed based on the EMI PowerFactory study case for 202311, available 
on the Electricity Authority’s website5. The winter 2024 variation has been considered for load 
conditions. The ISL 220 kV bus angle has been set as 0 degrees for power-flow solution.  

Users may replicate the power flow conditions by creating equivalents for other load condition 
variations or by updating the case using the latest version of the EMI study. For further assistance, 
please contact the system operator. 

 

4.1 Network Equivalents 

The network model contains network components associated with grid zones 9, 10, 11 and, 12. The 
rest of the network is represented by equivalent voltage sources and a reduced network model to 
simplify the EMT simulation.  

The slack generator was set to Coleridge G2 with the voltage angle of Islington 220 kV bus at 0°. The 
network was reduced in PowerFactory based on the following selected boundary of the EMI 
PowerFactory case.  

 

 

Figure 8: EMI PowerFactory boundary for reducing rest of the South Island power grid. 

 

Once the network boundary is created in PowerFactory (named Boundary-TWZ in this example), part 
of the network exterior to the boundary can be reduced via CALCULATION -> Network Reduction in 
PowerFactory. This will open the Network Reduction window. In this window, parameters should be 
set as follows to create an Extended Ward Reduction. Leave other settings as default. Once the 
settings are configured, press Execute6. 

 

5 Electricity Authority - EMI (market statistics and tools) (ea.govt.nz) 
6 Additional information regarding Network Reduction is available in the PowerFactory user manual. 

https://www.emi.ea.govt.nz/Wholesale/Datasets/Transmission/PowerSystemAnalysis/PowerFactoryCaseFiles


TRANSPOWER NEW ZEALAND   |   GRID ZONE 9, 10, 11, 12 EMT MODEL USER GUIDE 9 

 

Figure 9: Network Reduction window: Basic Options. 

 

 

Figure 10: Network Reduction window: Ward Equivalent. 

 

Once the network is reduced, AC voltage sources and Common Impedances appear in the 
PowerFactory network data. The magnitude, angle, initial active and reactive powers of the 
equivalent network AC voltage sources, as well as network impedances between equivalent AC 
voltage sources in the EMT model were set based on the power-flow solution of the reduced 
PowerFactory case.  

 

Figure 11: Network equivalent in EMT_9_10_11_12.pscx. 
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4.2 Network Models 

The network model consists of a detailed model of the USI region including hydro generation in the 
region, a generic STATCOM at Kikiwa, and two generic SVCs at Islington. The region of the South 
Island network within the green line in Figure 12 is covered in the network model. 

 

Figure 12: Region represented in the network model. 

 

4.3 Generation within the Region 

Name of the 
Generator 

Capacity (MVA) Dispatch (MW) Energy Source Model 

Coleridge (COL) 

11.5 

13.4 

13.4 

3.53 

3.53 

9.5 

6.4 

OOS7 

OOS 

OOS 

Hydro GENSAE 

 

7 OOS- Out of service 
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Amethyst (AMS) 9.25 3.0 Hydro GENSAE 

Kumara (KUM) 9.23 4.7 Hydro GENSAE 

Arnold (ALD) 
1.8 

1.8 

OOS 

OOS 
Hydro GENSAE 

Cobb (COB) 

3.75 

3.75 

3.75 

3.75 

11.1 

11.1 

2.6 

2.6 

2.6 

2.6 

8.9 

OOS 

Hydro GENSAE 

Argyle (ARG) 4.23 3.1 Hydro GENSAE 

Wairau (WAU) 7.778 OOS Hydro GENSAE 

Ohau A (OHA) 

73.33 

73.33 

73.33 

73.33 

65.9 

65.9 

48.0 

12.1 

Hydro GENSAE 

Tekapo B (TKB) 
88.9 

88.9 

77.2 

66.0 
Hydro GENSAE 

Tekapo A (TKA) 35.0 12.2 Hydro GENSAE 

 

4.4 Generator Models 

Due to the sensitivity of the information regarding models of generators, generic models have been 
used to model the generators. Synchronous machines are modelled using GENSAE models, with their 
automatic voltage regulators using respective IEEE generic models.  

 

4.5 Load Model 

The active and reactive power components of the loads at grid exit points (GXPs) are modelled as 
constant current sources and constant impedance models respectively to align with the widely 
accepted load dynamic characteristics8. 

 

8 Kundur, Prabha S., and Om P. Malik. 2022. Power System Stability and Control. 2nd ed. New York: McGraw 
Hill. 
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Figure 13: Example load representation. 

 

4.6 Reactive Power Compensation Devices 

The network model consists of three active reactive power devices. 

 Kikiwa STATCOM 
 Islington SVC3 
 Islington SVC9 

The reactive power compensation devices are developed with generic controls without their special 
protection mechanisms.  

  

Constant Current – Active 
Power Component

Constant Impedance – 
Reactive Power Component
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5.0 Update Initial Conditions using Power-flow Data 

 

The update_syncmachines.py and update_loads.py scripts can be used along with 
synchronous_machines.csv and loads.csv to rapidly update the initial conditions of the synchronous 
machines and load values based on the power-flow solution.  

 

5.1 Update Synchronous Machines 

Step 1 

First, the synchronous_machines.csv needs to be updated based on the power-flow solution. Figure 
14 gives an overview of the .csv file data format opened in Excel.  

Note: the user must not change the data order or format.  

 

 

Figure 14: Data format of the synchronous_machines.csv file. 

 

The same generator name used in the EMI case is used in the first column. Columns B and C can be 
left null or populated. Columns D to H need to be updated based on the PowerFactory power-flow 
solution. Once the .csv file is updated, save it in the same folder where the PSCAD case is saved. 

 

Step 2 

Add update_syncmachines.py as a resource to the PSCAD case. Figure 15 gives a snapshot of adding 
the python file to EMT_9_10_11_12.pscx 

 



TRANSPOWER NEW ZEALAND   |   GRID ZONE 9, 10, 11, 12 EMT MODEL USER GUIDE 14 

  

Figure 15: Addition of update_syncmachines.py script. 

 

Step 3 

Double-click the added update_syncmachines.py file. This will open a scripts pane in the PSCAD 
environment. 

 

Figure 16: Scripts pane with the loaded script. 

 

Step 4 

Update the project_name variable with the current PSCAD case that needs to be edited.  

Update the sync_machine_data variable with the absolute file location of the 
synchronous_machines.csv file. See Figure 17. 
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Figure 17: Update the project name and sync_machine_data variables. 

 

Step 5 

Press the Run button available in the Scripts pane. This should update the synchronous machines 
within the PSCAD case with the data provided in the synchronous_machines.csv file. The Script 
Output will be populated with generators that are being updated.  

 

5.2 Update Loads 

Step 1 

Update the loads.csv based on the power-flow solution. Figure 18 gives an overview of the .csv file 
data format opened in Excel.  

Note: The user must not change the data order or format.  

 

Figure 18. Data format of the loads.csv file. 
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The same load name used in the EMI case is used in the first column. Column B can be left null or 
populated. Columns C to F need to be updated based on the PowerFactory power-flow solution. 
Once the .csv file is updated, save it in the same folder where the PSCAD case is saved. 

 

Step 2 

Add update_loads.py as a resource to the PSCAD case like in section 5.1.  

 

Step 3 

Double-click the update_loads.py file. This will open a scripts pane in the PSCAD environment. 

 

Figure 19: Scripts pane with the loaded script. 

 

Step 4 

Update the project_name variable with the current PSCAD case that needs to be edited.  

Update the load_data variable with the absolute file location of the loads.csv file. See Figure 20. 

 

Figure 20. Update the project name and load_data variables. 
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Step 5 

Press the Run button in the Scripts pane. This will update the synchronous machines within the 
PSCAD case with the data provided in the loads.csv file. The Script Output will be populated with 
loads that are being updated. 
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6.0 Assumptions and Limitations of the Model 

The EMT_9_10_11_12.pscx PSCAD network model is provided with the following assumptions and 
limitations. 

• It contains Grid Zone 9, 10, 11 and 12 transmission networks modelled in detail, including all the 
associated voltage control system models for generators. The rest of the South Island network is 
modelled as equivalent networks, with equivalent generators modelled as a constant frequency 
AC voltage source. This PSCAD network model is suitable for fault ride through and other voltage-
related system studies.  

• The simulation model requires an Intel® Fortran Compiler Classic 2021.12.0 to compile the 
simulation case.    

• The simulation case was built using PSCAD version 5.0.2.0. 

• The simulation case was developed with Visual Studio 2022. 

• The EMT model has been created for a specific operating point of the power system (2024 
Summer loading in EMI case). Users can modify the system for different study scenarios using 
the python script provided.  

• The dynamics of machines are released at 3.0 s of the simulation run. Thus, it is recommended 
to run the simulation further about 3-5 s to ensure the system is in steady state. Verify the system 
is in steady state prior to conducting the studies. 

• The EMT model was converted from the power-flow file using a 20 µs simulation time step. Users 
could reduce the time step further if required, but increasing the simulation time step would 
likely result in errors when performing the simulation.  

• The simulation model used simplifies generic models for STATCOMs and SVCs due to the 
restrictions of using detailed models. The response of the generic models may not fully represent 
the behaviour of the actual asset(s). 

• The python scripts provided with the model only update the initial condition of generators and 
load values. The transformer tap positions, equivalent network initial conditions, and equivalent 
network impedances, solar PV farm power outputs, filter configurations, STATCOM and SVC 
setpoints and static capacitors and inductors within the system are NOT updated automatically. 
It is highly recommended that users verify all parameters and dispatch against the PowerFactory 
case.  
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